Veloster Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
Hi All,

After dealing with the stalling issue with my 2012 Veloster, which seems to be a problem with some other owners, as a new 2013 Veloster Turbo owner, I wonder if this model has known issues. So, please post them here. I think I recall someone from Australia having some stalling issues with VT Manual tranny. Anyone else or any other issues? I suppose I'm a bit paranoid now, but I'd like to get some idea how much more reliable VT is compared to Original V. Some people had problems with their DCT on original Veloster. Since VT has regular Auto tranny (as well as MT), there shouldnt be any issues with it's transmission, right?
Well, anyway - whatever it is - please let us know. I truly hope that my VT will be a problem free car. But in the event its not - it would be good to know what those potential problems are as well as how to fix them.
 

·
Registered
Joined
·
47 Posts
None.

The auto transmisson with paddle shifters works great. I second my new driving habbits...car is fun to drive so I find myself spooling the turbo more now the break end period is over...which results in speeding.

The only personality note is when you drive with the windows down it is best to drive with two windows cracked open. I prefer the sunroof open with the rear 3rd door window down just a little...gets air in the car moving all around.

FYI been in the car since August 2012.


I still enjoy every drive .....you will too....zoom >>>>>>>>>>>>>>>>>>>:cool:
 

·
Registered
Joined
·
336 Posts
My main problem with the VT is that it often takes me an extra 15 minutes or so to get home because I decide to go play in the hills on the way... open roads with twists and bends, what more could you want???
 

·
Registered
Joined
·
379 Posts
The turbo seems to be reliable and mine has not missed a beat or generated a rattle since new, and it's done over 7,000km. The reliablility of the turbo is quite impressive given it's the first time the delta motor has been turbocharged and it's an all-new automatic gearbox. Suspension, brakes and steering are from the Accent so they are well-proven. Some owners have reported quirky issues with the console system (system locking up, clock not refreshing).
 

·
Registered
Joined
·
3,992 Posts
The VT seems to be much more problem free the the NAV. Its slightly never, so the issues with the roof and rear brakes have probably been dealt with from the beginning. Also, it uses Hyundais normal auto tranny and not the DCT that is proving to be problematic.

I have 17,000kms (10,000miles) and my VT now and it has been problem free aside from the odd random rattle in the sub zero winter months. Im very happy with the car.
 

·
Registered
Joined
·
17 Posts
Loud Engine knocking noise at 4500 rmps when accelerating (must hold at 4500 steady and not dip), Turbo has gone into limp mode. Newest issue - codes P0300 P0301 P0302 P0303 appeared when car was idling at 1000-1500 rmps at light and almost stalled - started shaking in traffic and at light. Had to put car in neutral and hold rpms at 3000 to keep from stalling on friday. Now car has 2 bad spark plugs. The engine codes are from all 4 cylinders misfiring. The knocking comes from using 87 octane vs 93. Tested for a month with 93 worked fine, the day i put 87 back in the car knocked 6 times within 20 min (2 ten minute drives). Car has been in the shop since saturday. 5900 Miles on it, 5 months old. Noise since purchased. No codes for the first 5 months until friday....
 

·
Registered
Joined
·
137 Posts
Discussion Starter #14
Loud Engine knocking noise at 4500 rmps when accelerating (must hold at 4500 steady and not dip), Turbo has gone into limp mode. Newest issue - codes P0300 P0301 P0302 P0303 appeared when car was idling at 1000-1500 rmps at light and almost stalled - started shaking in traffic and at light. Had to put car in neutral and hold rpms at 3000 to keep from stalling on friday. Now car has 2 bad spark plugs. The engine codes are from all 4 cylinders misfiring. The knocking comes from using 87 octane vs 93. Tested for a month with 93 worked fine, the day i put 87 back in the car knocked 6 times within 20 min (2 ten minute drives). Car has been in the shop since saturday. 5900 Miles on it, 5 months old. Noise since purchased. No codes for the first 5 months until friday....
Sorry to hear about your problems. Please keep us updated in this thread how and if it gets resolved.
 

·
Registered
Joined
·
980 Posts
Or pcm
 

·
Registered
Joined
·
42 Posts
problem for me is gas milage lmao... during break in period i was getting average like 30-33 during my daily drive to school back and more now that that break in is done im like fighting to get to 28 lmao averaging around 23-24 xDD dammit lmao
 

·
Registered
Joined
·
79 Posts
I have heard a few people here and there talking about an issue with the first gear lockout that is supposed to keep you doing the famous "1-2-1 over-rev your motor" mis-shift. It was supposedly sticking and not letting people shift the car into 1st unlesss they were totally stopped, and then even sticking sometimes even when the car was stationary. I only saw it a couple times, and have never had any issue with my VT. But, then again, I hevn't even made it to 100 miles yet...It was probly an isolated issue...
 

·
Registered
Joined
·
784 Posts
Only niggly things like a couple of rattles, hard plastic cupholders and storage spots that mean loud scraping of stored objects and a peeling steering wheel. Apart from that im really enjoying it while I wait for the Genesis Coupe to be released in Australia ;)

Sent from my GT-N7105 using AutoGuide App
 
1 - 20 of 39 Posts
Top