Veloster Forum banner

1 - 20 of 63 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter #1 (Edited by Moderator)
I've had my V since late November and use a 16GB USB stick to store the songs I like to carry with me. Up until about two weeks ago when I changed to USB input it would start playing where it left off the last time I played from the USB stick.

Now, every time I access the USB stick, it starts from the beginning of the first song in the first directory. A HUGE pita.

At times I add or delete directories and I have a lot of them on the stick. Is there a limit to the number of directories the Tech Package HU can keep track of before it has to restart? I've heard some issues of people using a 64GB stick having trouble when they go over 32GB but not this.

Any helpful thoughts are appreciated.

UPDATE: TRY THIS PROCEEDURE IF YOU ARE HAVING ISSUES:

http://www.veloster.org/forum/35-hyundai-veloster-audio-electronics/4618-usb-audio-starts-first-song-every-time-now.html#post75247
 

·
Registered
Joined
·
26 Posts
If you turned on gracenote, turn it off. It's a known and very annoying bug. Other than that, maybe reformat the USB and add the files back on, although I doubt that's the problem.

Now if I can only get my iPhone to stop playing a random song from the middle of the "all songs" selection (which I never use) whenever I plug it into the V...
 

·
Registered
Joined
·
294 Posts
Discussion Starter #3
I don't have "gracenote" turned on. I'll try reformatting the thumb drive.
 

·
Registered
Joined
·
294 Posts
Discussion Starter #4
I reformatted the drive (quick) and that didn't help. I reformatted the drive (full) and that didn't help. I tried two other thumb drives and that didn't help either.

I took it to the dealer and a "tech" worked on it all day. According to Hyundai it's supposed to start where it left off every time no matter whether you change to another source, put the HU in standby, turn the HU off or turn the car off.

Anyway, they've order a new HU for me and they say it's backordered. Since it's just a nuisance thing I'm not upset but who knows when it'll arrive.
 

·
Registered
Joined
·
171 Posts
I'm a bit surprised that your dealer is going to replace your HU over this issue. I am using a popular 32 GB USB drive. Sometimes, it starts where it left off and sometimes it starts at the first file in the first directory. I have not made changes to the drive or used Gracenote. It does not seem to matter whether I leave the USB drive connected or pull it out between uses.

I have not noticed what conditions (e.g., changes in HU input source or settings) may be causing the USB drive to start at the first file rather than where it left off. Has anyone noticed a pattern?
 

·
Registered
Joined
·
30 Posts
Before turning off your car, turn the AV off. Don't turn off the screen. That works for me every time, the USB drive picks up where it left off last time I turn off the AV. Hope you can reproduce this.
 

·
Registered
Joined
·
30 Posts
Before turning off your car, turn the AV off. Don't turn off the screen. That works for me every time, the USB drive picks up where it left off last time I turn off the AV. Hope you can reproduce this.

yakanism, many thanks. Your suggestion was a big help.

All the best,
 

·
Registered
Joined
·
1,444 Posts
UPDATED: THIS SHOULD RESOLVE ISSUE

For anyone having this issue or dealers who need to solve the problem without replacing the head unit:

PROBLEM

  • The last song played or resume data is stored in a file called: IRIS_USBLastResume.dat
  • Iris is the name of the executable or module that plays USB audio in the LG interface.
  • When the USB playback is paused, switched to XM or radio, the head unit writes to a that file with the location and name of the last song played.
  • If that file gets corrupt or the MP3 is gone or corrupt the head unit will just default to playing from the start.
  • In some cases the folder gets corrupted or the mandatory files in the folder don't exist.
DIRECTIONS TO FIX (DO AT YOUR OWN RISK AND BE CAREFUL)

 

Attachments

·
Registered
Joined
·
2,765 Posts
Very interesting. I've been running a normal size Sandisk 8 GB USB stick without so much as a hiccup, ever. I've recently picked up 2 16 GB Sandisk dime sized drives and hope they work as well as the larger sized, smaller volume drive. If not, I'll follow Dezoris's advice.
 

·
Registered
Joined
·
16 Posts
I've had this problem since day one. Sometimes it resumes, but most of the time it does not.

I've also had this problem as of late too. The boot up screen that shows the Veloster when first starting the car does not go away. I have to manually hit the clock button to get out of that screen. Then my clock doesn't update the time. I have to keep hitting the clock button to refresh the time. Bugs... lots of bugs in the software.
 

·
Registered
Joined
·
171 Posts
Before turning off your car, turn the AV off. Don't turn off the screen. That works for me every time, the USB drive picks up where it left off last time I turn off the AV. Hope you can reproduce this.
I sometimes press and hold the power button before turning off Vster so I can see my loaded screensaver instead of that red Veloster upon startup, but perhaps this is "turning the screen off." Please clarify how to turn the AV off without turning the screen off. Would hitting the "setup" button do the trick?
 

·
Registered
Joined
·
30 Posts
MJSykes, don't press and hold the power button. Just push the button once before turning off the V, that's how you'd see "AV off" on the screen. The next time you turn on the car, again, just push the power button once (don't press & hold) and the car will pick up where it was left off last time. Hope you or somebody can reproduce this as it works for me everytime.
 

·
Registered
Joined
·
309 Posts
On a separate (but related) issue, my iPhone also randomly starts at the beginning of my song list instead of where I left off. I was really sick of hearing the start of that same song over and over again, so I created a 1 minute "song" that is complete silence. I named the song "AA" so it would always be first alphabetically. Now when the Veloster messes up, I just get silence! And I have 1 minute to pause it or select a different song.
 

·
Registered
Joined
·
2,663 Posts
On a separate (but related) issue, my iPhone also randomly starts at the beginning of my song list instead of where I left off. I was really sick of hearing the start of that same song over and over again, so I created a 1 minute "song" that is complete silence. I named the song "AA" so it would always be first alphabetically. Now when the Veloster messes up, I just get silence! And I have 1 minute to pause it or select a different song.
That's a known side effect of having Gracenote enabled if it always happens, I now know all the words to A by BNL. It will also do that if the iphone/ipod has had the DB rewritten with new songs from a sync and no longer has a "last song played" up in "Now Playing"
 

·
Registered
Joined
·
294 Posts
Discussion Starter #15
For anyone having this issue or dealers who need to solve the problem without replacing the head unit: (Aside from the other suggestion)

PROBLEM
  • The last song played or resume data is stored in a file called: IRIS_USBLastResume.dat
  • Iris is the name of the executable or module that plays USB audio in the LG interface.
  • When the USB playback is paused, switched to XM or radio, the head unit writes to a that file with the location and name of the last song played.
  • If that file gets corrupt or the MP3 is gone or corrupt the head unit will just default to playing from the start.
DIRECTIONS TO FIX (DO AT YOUR OWN RISK AND BE CAREFUL)
So I tried the above and was not successful in fixing the problem.

First: I have "My Device" but can't find "My Media".
IMG-20120402-00003.jpg
Second: it looks like the "\Storage Card2\DATA\Iris" directory isn't write enabled.
IMG-20120402-00001.jpg
Also, below is photo of the software version in my HU, Dimension/Tech.
IMG-20120402-00004.jpg
So, I'm still stuck with this issue.

FYI: I've tried turning the HU off (soft off and hard off) and that doesn't work either.
 

·
Registered
Joined
·
309 Posts
That's a known side effect of having Gracenote enabled if it always happens, I now know all the words to A by BNL. It will also do that if the iphone/ipod has had the DB rewritten with new songs from a sync and no longer has a "last song played" up in "Now Playing"
I've never used Gracenote, and it is still about 50/50 for me, even if I haven't done any kind of sync. I honestly have no clue what causes it, or how to avoid it. But it doesn't really bother me any more now that I have added the silent track. Hopefully they will give us a head unit update at some point. I actually thought they would have done it by now.
 

·
Registered
Joined
·
294 Posts
Discussion Starter #18
I will get back to you with two other things to try.
Thanks, at least I get to try something.

This is frustrating though understandable. Windows CE is somewhat kludgy.
 

·
Registered
Joined
·
22 Posts
My Gracenote is always off, AV is always off, I never unplug the usb flash drive and......... sometimes V remember the mp3 and start playing where it left off, sometimes starts from first mp3.


Any update? any workaround?
 

·
Registered
Joined
·
309 Posts
I would recommend putting a silent mp3 as the first song like I did with my iPhone. It's not a fix, but it makes the bug wayyyy more tolerable.
 
1 - 20 of 63 Posts
Top