Veloster Forum banner
1 - 13 of 13 Posts

Registered
Joined
11 Posts
Discussion Starter · #1 ·
Just installed a sxth axel back. Car now feels sluggish. I dont want to do any tu ingot due to warranty. Might switch back to stock bc car felt alot better. Why would an axel back affect it this much? I also heard that the ECU will automatically adjust to any bolt ons on it's own?.. is that true and has anyone had this happen?
 

Registered
2015 RB Accent not so stock 馃か
Joined
1,017 Posts
It shouldn't have gone sluggish on you at all.
Double check to make sure that everything is installed correctly and the gaskets didn't move while bolting it up and causing exhaust restriction.

Try resetting the ecu as well and see if that helps. Disconnect negative post on your battery, step on your brakes while disconnected for 30 seconds, and reinstall negative post.

When I installed my secondary cat delete and custom axle back there was no loss of power at all. I gained power in the mid and upper rev range.

Good luck and hope it all works out.
 

Registered
Joined
11 Posts
Discussion Starter · #3 ·



  1. It shouldn't have gone sluggish on you at all.
    Double check to make sure that everything is installed correctly and the gaskets didn't move while bolting it up and causing exhaust restriction.

    Try resetting the ecu as well and see if that helps. Disconnect negative post on your battery, step on your brakes while disconnected for 30 seconds, and reinstall negative post.

    When I installed my secondary cat delete and custom axle back there was no loss of power at all. I gained power in the mid and upper rev range.

    Good luck and hope it all works out.
    Is yours on stock tune? Also how long should I leave the neg disconnected? 30 sec or leave it for longer afterward? Thank you for the advice though
 

Registered
2015 RB Accent not so stock 馃か
Joined
1,017 Posts
Stock tune.
Once you disconnect your negative post go into the car and apply your brakes for about 30 seconds.
What this does is takes out any electrical charge from any capacitive circuits in the car and depletes any left over voltage from the system.
Then hook up your battery again and you should be reset. ?
 

Registered
16 VT
Joined
1,241 Posts
Just installed a sxth axel back. Car now feels sluggish. I dont want to do any tu ingot due to warranty. Might switch back to stock bc car felt alot better. Why would an axel back affect it this much? I also heard that the ECU will automatically adjust to any bolt ons on it's own?.. is that true and has anyone had this happen?
Sum ting wong.
 

weekend racer
2014 VT manual
Joined
8,831 Posts
which axleback?

borla or magnaflow? i don't see anything else advertised on their site for NAV.
 

weekend racer
2014 VT manual
Joined
8,831 Posts
non turbo veloster. Naturally Aspirated Veloster.


maybe you could give us more info on yours.
 

weekend racer
2014 VT manual
Joined
8,831 Posts
that makes sense now, you didn't post in the 2nd gen forum. i'll move this.


reset the ECU and if you're still having trouble report back to sxth. but this shouldn't have any bearing on what power the engine is making. i don't think you would be hitting any of the power limiters in the ECU.
 
1 - 13 of 13 Posts
Top