Veloster Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello All,

I have a 2016 Hyundai Veloster. Last night while driving my car would not accelerate and the Safe Protection Mode appeared. I have had several suggestions of disconnecting the cables on the battery, did so, no change. Have anyone else experienced this, if so what was the outcome. Any suggestions?
 

· Administrator
Joined
·
4,738 Posts
Get your codes read at a auto parts store and report back
 

· Registered
Joined
·
4 Posts
It’s a Dct isn’t is? It seems to be a problem every year with these models. I have been going through the same thing and mines 2013. It’s ridiculous and now I see why they are officially discontinuing this cars!
 

· weekend racer
2014 VT manual
Joined
·
9,729 Posts
lol that isn't why they are discontinuing them. they are phasing out everything for EV except for performance models.

in your case though hyundai was very late to the game with DCT technology but all car makers do this, put new trans tech in their cheapest cars before moving up to the more expensive ones.
 
  • Like
Reactions: Luximo1

· Registered
Joined
·
29 Posts
lol that isn't why they are discontinuing them. they are phasing out everything for EV except for performance models.

in your case though hyundai was very late to the game with DCT technology but all car makers do this, put new trans tech in their cheapest cars before moving up to the more expensive ones.
Sound 'bout right...🤌🏼
 
1 - 5 of 5 Posts
Top