Veloster Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi everyone, I had had my velostar 2012 for a year now. Not long after I bought it the navigation system starting freezing, I took it to Hyundai and they said they could do a software update but said they wouldn't guarantee that it will fix it. They said that it will either fix it or break it. It wasn't working so I opted for the software update. It worked for a little while then slowly it started freezing again, particularly if the car had been in the hot sun, even with a screen protector on.
It now is worse than ever. It is totally frozen on the touch screen and spends the whole time beep beep beeping and jumping all over the place, totally useless.
Any thoughts from anyone, please, its driving me mental, thanks Jill
 

·
Registered
2012 Veloster NA, 71 VW Type 3 Fastback, 70 VW type 3 Fastback, 2011 TDI Sportwagen, 99 impreza
Joined
·
308 Posts
Mine does that after sitting in the hot sun (usually above 90*) i suspect the fix is replacing the headunit as electronics don't like heat.

Factory units and aftermarket android units exist that just plug right in for around $300-400
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Mine does that after sitting in the hot sun (usually above 90*) i suspect the fix is replacing the headunit as electronics don't like heat.

Factory units and aftermarket android units exist that just plug right in for around $300-400
Thanks so much for your reply, I guess I will just book it in to Hyundai again, I wonder why they never offered it in the first place, anyway, I will see how I go!
 

·
Registered
2012 Veloster NA, 71 VW Type 3 Fastback, 70 VW type 3 Fastback, 2011 TDI Sportwagen, 99 impreza
Joined
·
308 Posts
If it's covered under warranty likely because it's expensive to replace and they don't want to do it.

I've never paid others (dealerships, 3rd party mechanics or otherwise) to work on my cars. But headunit replacement shouldn't take more than an hour.
 

·
weekend racer
2014 VT manual
Joined
·
7,964 Posts
if youre getting a bunch of beeps i would wonder if the touch screen needs to be cleaned... maybe there is something jammed into the edge of the bezel.

also do you connect your phone? maybe try setting the headunit so it doesn't download your contacts?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Thanks so much, no warranty I'm afraid. I wish I could work on my own cars lucky you 😁👍
if youre getting a bunch of beeps i would wonder if the touch screen needs to be cleaned... maybe there is something jammed into the edge of the bezel.

also do you connect your phone? maybe try setting the headunit so it doesn't download your contacts?
Hi thank you so much for your thoughts, what is a bezel? I will try to clean it... beeps like crazy....
My phone is connected via Bluetooth, should I turn off Bluetooth and see if it still does it? Do you mean?
 

·
weekend racer
2014 VT manual
Joined
·
7,964 Posts
The bezel is the plastic around the touchscreen.
In the settings somewhere it has a button for turning off contact download, I’d check that first
 

·
Registered
Joined
·
3 Posts
Hi everyone, I had had my velostar 2012 for a year now. Not long after I bought it the navigation system starting freezing, I took it to Hyundai and they said they could do a software update but said they wouldn't guarantee that it will fix it. They said that it will either fix it or break it. It wasn't working so I opted for the software update. It worked for a little while then slowly it started freezing again, particularly if the car had been in the hot sun, even with a screen protector on.
It now is worse than ever. It is totally frozen on the touch screen and spends the whole time beep beep beeping and jumping all over the place, totally useless.
Any thoughts from anyone, please, its driving me mental, thanks Jill
Hi Jill,
If you do decide to take it back to Hyundai, be strong and make sure they refund ALL the money you spent with them, because that did not fix your problem. You might even want to think about taking it to a specialty shop, a business that actually specializes in that.
I recently took my Veloster to Hyundai, they said I needed a new transmission. So I took it to a transmission specialist for a second opinion. If fact I didn't need a transmission. So I'm just saying, don't let the dealership rip you off.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
Hi Jill,
If you do decide to take it back to Hyundai, be strong and make sure they refund ALL the money you spent with them, because that did not fix your problem. You might even want to think about taking it to a specialty shop, a business that actually specializes in that.
I recently took my Veloster to Hyundai, they said I needed a new transmission. So I took it to a transmission specialist for a second opinion. If fact I didn't need a transmission. So I'm just saying, don't let the dealership rip you off.
Hey, thanks so much for the information, I totally agree with you but not sure what other place to take it? Do you mean another mechanic or what type of business would specialise in this problem, do you think?
 

·
Registered
Joined
·
76 Posts
Have you done a hard reset? You should find a pin hole by the CD player. Use a paper clip. With the car in RUN mode but without the engine running. The console should be on. Insert and hold for about 10 seconds and you will see the unit shut off and reboot. See if that fixes the problem.

I had similar issues as well as blue tooth problems. I tried the dealer, took them 3 hours to do a 45min update. Then it was the same firmware. So i ordered the USB direct from Hyundai and did it myself. Connected battery to my trickle charger, insert USB and then turn car to RUN but not start engine. Console will boot to the USB and prompt to update. Hit yes and it took about 45min. Then check firmware version is newer.

It runs on a version of Windows CE so its read only unless using a USB update package.

When i first had issues I ordered a good used OEM head unit because i figured mine was toast. While waiting i found the update and fixed it so now I have a spare 2012 Veloster none turbo head unit I dont need.

Later i had blue tooth issues with my new phone and found a 2015 sonata had the same head unit so i got the Sonata update and it worked. Now no problems. If you want, I can try to find it for you if you have the same head unit as me. Mine has no camera but does have Blue Stink, CD, Radio, Satalite XM, Pandora App, no GPS. Maybe tomorrow ill look up the firmware version and you can compare it and see if you are behind and need an update. Let me know. My guess is you just need to update it or reset it.
 

·
Registered
Joined
·
76 Posts
Agreed. Get yourself some plastic pry tools because its hell a easy to scratch the bezel. I ended up repainting mine. Then its maybe 4 screws and a wiring harness to remove and swap.
 

·
Registered
Joined
·
76 Posts
Here is the software version and model of my head unit. Again, for a 2012 Veloster NONE TURBO. Manual transmission. Head unit does NOT have GPS button or backup camera.

Only has Blue Stink, XM radio, AM/FM and CD player as well as Pandora touch button.

133728
 

Attachments

·
Registered
Joined
·
76 Posts
Im having prpblems with the mobile version of this site and posting so sorry if it repeats. Here is a pic of my software version etc including the bluetooth version. If you have the same head unit but not up to date, i would try updating it with the version I have.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
Have you done a hard reset? You should find a pin hole by the CD player. Use a paper clip. With the car in RUN mode but without the engine running. The console should be on. Insert and hold for about 10 seconds and you will see the unit shut off and reboot. See if that fixes the problem.

I had similar issues as well as blue tooth problems. I tried the dealer, took them 3 hours to do a 45min update. Then it was the same firmware. So i ordered the USB direct from Hyundai and did it myself. Connected battery to my trickle charger, insert USB and then turn car to RUN but not start engine. Console will boot to the USB and prompt to update. Hit yes and it took about 45min. Then check firmware version is newer.

It runs on a version of Windows CE so its read only unless using a USB update package.

When i first had issues I ordered a good used OEM head unit because i figured mine was toast. While waiting i found the update and fixed it so now I have a spare 2012 Veloster none turbo head unit I dont need.

Later i had blue tooth issues with my new phone and found a 2015 sonata had the same head unit so i got the Sonata update and it worked. Now no problems. If you want, I can try to find it for you if you have the same head unit as me. Mine has no camera but does have Blue Stink, CD, Radio, Satalite XM, Pandora App, no GPS. Maybe tomorrow ill look up the firmware version and you can compare it and see if you are behind and need an update. Let me know. My guess is you just need to update it or reset it.
Wow, I really appreciate you taking the time to write this. I have tried the reset but car was running. Totally keen to try again. Thanks a million :)(y)
 

·
Registered
Joined
·
13 Posts
Discussion Starter #16
Wow, I really appreciate you taking the time to write this. I have tried the reset but car was running. Totally keen to try again. Thanks a million :)(y)
sorry I just saw the rest of your post - I am not sure of what software I have or how to find out - my touch screen is useless and completely frozen. I am so damn frustrated with this and I am not car savvy when it comes to technical stuff - I have taken all on board what you said and will try to find out. Probably doesnt help that you are in USA and I am in Australia but I really appreciate the help you are trying to give me!
 

·
Registered
Joined
·
76 Posts
No problem. The reset hole by the CD drive, when its on or in the run and on position you can press and hold the paperclip in the hole and it should go blank if your doing it right. Then the system will reboot at factory default.

Its been a while but if that doesnt work. You can hold it in while you turn on the car and see if that resets it. Some combination of that.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #19
No problem. The reset hole by the CD drive, when its on or in the run and on position you can press and hold the paperclip in the hole and it should go blank if your doing it right. Then the system will reboot at factory default.

Its been a while but if that doesnt work. You can hold it in while you turn on the car and see if that resets it. Some combination of that.
Hi there @buschchris1 ... I tried the reset in run mode and it definitely went off and then turned on again and occasionally it will now let me use it but keeps beeping and defaulting back to the screen that shows you longitude and latitude etc, so in the middle of the journey it goes back to that and I have to keep hitting the 'map' button to return to maps (and my journey) so it kind of helped - thank you. I think I will just book it into hyundai and see what they think. I am really appreciative of your great help :)
 
1 - 20 of 28 Posts
Top