Veloster Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I need help please. My Veloster does not move when put on reverse. Instead the “R” on the dashboard just blinks. Other gears switch well. It’s been the same for a few days now. Any idea what could be the issue?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Remove the negative battery terminal on your car battery, wait about 1 min then put it back.

Test the car, if the problem persists, could be your gate shift actuator.
Thank you for your reply. I have done this and still no luck. The problem started after i drove through a lot of water.
 

·
Registered
2013 NA Veloster DCT
Joined
·
5 Posts
I had a blinking transaxle indicator myself a month ago. Your DCT is essentially 2 manual transmissions put together where one half controls the odd gears and REVERSE and the other handles the even gears.
With my issue, the clutch actuator motor that controlled my even gears gave way, so I couldn't shift out of 1st or go into reverse. Also, the issue was intermittent, but frequent. Do you have issues with a smooth shift from 1st to 2nd?

My part was 700 dollars alone and the job for the shop was 1200.
It really sucked when this happened. It was right after I bought the car and I will say that my car smelled like mildew when I first got it. I wonder if the same thing happened to the previous owner and he traded it in because Clutch Actuator B is located in a place there water can easily go up into. Hopefully it's something less costly for you. See my video for reference.

 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I had a blinking transaxle indicator myself a month ago. Your DCT is essentially 2 manual transmissions put together where one half controls the odd gears and REVERSE and the other handles the even gears.
With my issue, the clutch actuator motor that controlled my even gears gave way, so I couldn't shift out of 1st or go into reverse. Also, the issue was intermittent, but frequent. Do you have issues with a smooth shift from 1st to 2nd?

My part was 700 dollars alone and the job for the shop was 1200.
It really sucked when this happened. It was right after I bought the car and I will say that my car smelled like mildew when I first got it. I wonder if the same thing happened to the previous owner and he traded it in because Clutch Actuator B is located in a place there water can easily go up into. Hopefully it's something less costly for you. See my video for reference.

Thank you for the reply. At times the car revs at high rpm on "D" and jerks sometimes and that's about it. And mine isn't intermittent. The car simply wont move in "R".
 
1 - 5 of 5 Posts
Top