Veloster Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Could it be that the end links are too long and that I have to get adjustable ones? it's a piece front bar set to its stiffest setting, it actually sounds like the bushings are creaking since we only installed it yesterday.
 

·
Registered
Joined
·
66 Posts
Could it be that the end links are too long and that I have to get adjustable ones? it's a piece front bar set to its stiffest setting, it actually sounds like the bushings are creaking since we only installed it yesterday.
The one thing I learned about on installing aftermarket sway bars with poly bushings and no ZERK fittings to grease them is that eventually they will squeak after they get hot. I had the Pierce front bar installed on my 14 R Spec VT when I had it and even though I used the special grease that comes with it my front end started to squeak after one run thru the Dragons Tail. When I got home I used my motorcycle chain oil and sprayed on top of the sway bar bushings. The squeak went away and now and then would rear its ugly head and I sprayed again. my two last new camaros both had after market sway bars with zerk fittings at the mounts. they never squeaked. Guess you better get some chain oil?
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
yammyboy
Veloster Forum
The top Hyundai Veloster Forum to discuss your favorite 3 door car including the Veloster Turbo and Veloster N, as well as check out users mods to make the Hyundai Veloster faster!
Full Forum Listing
Top