Veloster Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Info on car, 2012 nav, non turbo, auto dual clutch 178000 miles.
Was turning into the road I live off of and engine dies, all of the other electronics were still on dash,radio,headlights.
tried to put car in neutral while coasting for a place to pull over, but shifter would not move. After I had came to a stop, tried again to place shifter in park and again would not release and move. Popped the little black cap and depressed the unlock button shifter moved to park position. Tried to restart car several times but nothing, no engine rotation no sounds no nothing. Got car back to the house and started looking for issues. While hunting for culprit, I noticed that while I was pressing the brake pedal the push button would only light up as far as the acc, but if i did'nt press brake pedal it would light up to on position. During all this I still have no rotation,no clicks moans groans nothing. Reading thru the forums it seemed that the brake switch was the most likely culprit, changed it out, no change in condition. So read some more, this where I have gotten so far with no changes.
2 codes found B2AAA Body, U0100 Network.
New brake switch
Removed every fuse and ohm'ed them out just to be sure
New battery, clean terminals, its been hot in Ga and battery was tested to be on the less than best condition 3 years old.
Sanded and cleaned all 5 of the grounding straps
Starter works and has no funny sounds or dragging if terminals are jumped from fuse box
Checked transmission inhibit switch best I could,shows on dash proper gear selection
I've tried the 30 second trick, while doing that lights on dash and radio come on, after 15 or so seconds of holding start button the radio screen goes off lose several of lights on dash and no engine rotation. Thats with brake pedal pressed and released tried both ways.
I've tried holding and pushing the start button with the key fob, same as above. The Fob as I can tell is operating normally will lock unlock set alarm off from a distance away. I only have one fob as car was bought used. New battery was installed as well.
I've tried using Bluelink to start car, I get the text that message that request was processed. But no vroom vroom.
If I have missed something please let me know, trying to save a trip to dealership, but it looks that it is in the near future.
 

·
weekend racer
Joined
·
6,462 Posts
U0100 is something with the ECU or canbus... not sure what the other code is unfortunately.
 
1 - 4 of 4 Posts
About this Discussion
3 Replies
3 Participants
Blaster
Veloster Forum
The top Hyundai Veloster Forum to discuss your favorite 3 door car including the Veloster Turbo and Veloster N, as well as check out users mods to make the Hyundai Veloster faster!
Full Forum Listing
Top