Veloster Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Okay, so I purchased a used 2013 tech veloster from a used car dealership, and the steering wheel controls on the left side (volume up/down, mode, skip track, calling buttons) didn't work. The dealer attempted to fix it, but was not able to so he advised me to bring it to the Hyundai dealership and have them look at it and he would reimburse me. I booked an appointment at the Hyundai dealership, and brought it in today. They replaced the switch, I payed, got in the car and drove off. It worked for about 2 minutes and then back to nothing again. I turned around and let them know what happened. They took it back in and are thinking that it's an issue with the head unit now.

Anyone with experience about this? I asked about the clock spring, but he said he does not think that is the issue... volume controls on the steering wheel are quite important to me.. and I'd really like to have this fixed.. The manager of the Hyundai dealership is supposed to call me tomorrow to discuss options because he was not available today...
 

·
Registered
Joined
·
11 Posts
Well I have the same issue, reason why I'm here too. But mine started with the volume and then other buttons just stopped working over time. Including the air bag light staying lit, lights on steering wheel not lighting up, and horn stopped working. I replaced my clock spring and so far it fixed the horn issue, the lights on the steer wheel and about all the button on it, EXCEPT the volume up and down. Oh and air bag light is still on. Womp womp
 

·
Registered
Joined
·
2 Posts
Okay, so I purchased a used 2013 tech Veloster from a used car dealership, and the steering wheel controls on the left side (volume up/down, mode, skip track, calling buttons) didn't work. The dealer attempted to fix it, but was not able to so he advised me to bring it to the Hyundai dealership and have them look at it and he would reimburse me. I booked an appointment at the Hyundai dealership and brought it in today. They replaced the switch, I paid, got in the car and drove off. It worked for about 2 minutes and then back to nothing again. I turned around and let them know what happened. They took it back in and are thinking that it's an issue with the head unit now.

Anyone with experience about this? I asked about the clock spring, but he said he does not think that is the issue... volume controls on the steering wheel are quite important to me. and I'd really like to have this fixed.. The manager of the Hyundai dealership is supposed to call me tomorrow to discuss options because he was not available today...

Same problem I encounter now also. How much did you pay?
 

·
weekend racer
Joined
·
6,487 Posts
wonder if it's the clockspring instead...
 
1 - 4 of 4 Posts
Top