Veloster Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
When I bought the Veloster I was under the impression that the touch screen would allow satnav etc on the head unit. Surprise, surprise- no such luck in South Africa at the time.
So I went looking for a better unit that would fit nicely into the car and found several Android units available on aliexpress (I hope I am not in violation of forum rules). These unit run Android 6 or Android 7 and looked awesome, so even though I was quite apprehensive, I ordered one. If your Veloster has a factory fitted amplifier then you need to add a CANBUS decoder to your oder.
Once the unit arrived, I tested it on my desk with a desk power supply and some speakers I has lying around. It all worked fine so I progressed to the car, where I had the disappointment of my life; everyting worked as expected, except there was NO SOUND. rather ironic for a radio. After much communication with the seller, it turned out that a brown wire (marked 'amplifier' in the radio harness and 'Amp Ctrl' in the CANBUS decoder harness) has to be connected together. Once this was done it all worked perfectly.

The steering controls are programmed using an app on the radion and they all work. The aircon display on the radio works fine (but I believe this also needs the CANBUS decoder).

I now have an awesome radio in the Veloster while retaing the most of the original equipment - only the head unit was replaced.
The radio is a Navitopia by the way.:D
 

·
weekend racer
Joined
·
7,549 Posts
Hi there, no rules violated and thanks for the info! Happy you were able to sort out the installation and controls easily.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Adding TPMS

I have now ordered a set of tyre pressure monitor valves (cost £20) with a bluetooth interface and an app that runs on the radio. So I can check my tyres from inside the car. I will post here as to how successful they are. The locally available version costs about £150, which is a bit over the top. Then, of course, you have to add installation in both cases. The valves replace the normal air valves on the wheels. And then re-balance the wheels.Might as well use the available features on the radio.:D
 

·
Registered
Joined
·
315 Posts
Very nice - glad it worked out for you. Keep us up to date with how it's working, I might go down this path if the factory unit gives me grief. Do all the features work correctly, does Bluetooth use the Veloster microphone or did you have to install your own, things like that. I see several on alieexpress, not sure which one you bought.


Thanks,

Rick
 

·
Registered
Joined
·
928 Posts
The aircon display on the radio works fine (but I believe this also needs the CANBUS decoder).

I now have an awesome radio in the Veloster while retaing the most of the original equipment - only the head unit was replaced.
The radio is a Navitopia by the way.:D
Would it be possible for you to grab a picture showing the aircon controls on the screen? If it's not too much of a bother could you please also share the link to the unit that you purchased?

Thanks
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Sadly I have had a setback this morning. The sound has stopped working and some of the controls are no longer functional. I need to take it out and check whether the wiring has gone wrong or something has packed up. I suspect the canbus decoder, as it turns the amplifier on and off. I sincerely hope it is not the radio. As soon as I have it sorted I will post the photos of the screen with the aircon info on it.<br>The link is: <br>https://www.aliexpress.com/wholesale?catId=0&initiative_id=SB_20180207005856&SearchText=veloster+navitopia<br>There is a selection of different sellers.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Some updates.<br>I got the Chinese tyre pressure monitor valves. They work fine in the mobile phone OUTSIDE THE CAR. The signal is too weak inside the card. So sad too bad.
 

·
Registered
Joined
·
315 Posts
Some updates.<br>I got the Chinese tyre pressure monitor valves. They work fine in the mobile phone OUTSIDE THE CAR.
Morning chuckle...have this mental image of you driving down the highway with your phone hanging outside your window.

Any luck yet with the stereo issue?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
Any luck yet with the stereo issue?
After much testing it seems the CANBUS decoder has packed up. I am now waiting for a replacement. but delivery from China is 60 days, so patience is needed (damn).

The decoder handles 3 things as far as I can work out: the canbus control of the amplifier and the display of the aircon info on the radio screen and converting analogue audio to spdif. Lets hold thumbs as it is an awesome radio when it works.
 

·
Registered
Joined
·
315 Posts
Hey Shumifan - how's it going? Did you ever get the radio issues resolved?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
Hi,
Yes the radio is resolved. It turned out to be a faulty CANBUS decoder. I received a replacement about 2 weeks ago, fitted it and now everything is peachy. This can only be a problem when the radio has an external amplifier fitted under the seat.
Also attached a photo of the aircon display on the radio as requested. 20180425_152455.jpg
 

·
Registered
Joined
·
6 Posts
Hi,
Yes the radio is resolved. It turned out to be a faulty CANBUS decoder. I received a replacement about 2 weeks ago, fitted it and now everything is peachy. This can only be a problem when the radio has an external amplifier fitted under the seat.
Also attached a photo of the aircon display on the radio as requested. View attachment 122217
to appear this air conditioning information was it necessary to add a canbus decoder?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #14
I never specifically checked, however, I have the feeling that the other integration (other than the external amplifier) was working, even after the CANBUS decoder broke.
 

·
Registered
Joined
·
9 Posts
Oi o meu carro tem uma unidade de cabeça chinesa, o som está funcionando, mas o subwoofer ficou muito fraco, acredito que possa ser o codificador SPDIF da unidade que não consegue emular o somcorretamente para o amplicador que fica sob o assento. A unidade é similar a sua. Como ficou o som so seu subwoofer?
 

·
Registered
Joined
·
9 Posts
Oi o meu carro tem uma unidade de cabeça chinesa, o som está funcionando, mas o subwoofer ficou muito fraco, acredito que possa ser o codificador SPDIF da unidade que não consegue emular o somcorretamente para o amplicador que fica sob o assento. A unidade é similar a sua. Como ficou o som so seu subwoofer?
Sorry.
english version:

Hi my car has a Chinese head unit, the sound is working, but the subwoofer got very weak, I think it might be the SPDIF encoder of the unit that can not emulate the sound for the amplifier under the seat. The unit is similar to yours. How did the sound become your subwoofer?
 

·
Registered
Joined
·
6 Posts
[QUOTE = shumifan49; 1314506] Oi,
Sim , o rádio está resolvido. Acabou sendo um decodificador CANBUS defeituoso. Eu recebi um substituto cerca de 2 semanas atrás, montado e agora tudo é peachy. Isso só pode ser um problema quando o rádio tiver um amplificador externo instalado sob o assento.
Também anexou uma foto do display aircon no rádio, conforme solicitado. View attachment 122217 [/CITAR]


I can not get the aircon information on the screen at all, do you know which version of the canbus you are using? And something about installing it? thank you
 

·
Registered
Joined
·
6 Posts
the aircon information appeared on the screen with the broken bus can? could you tell me how it is configured on the canbus screen of the factory settings options? as shown in this video
 

·
Registered
Joined
·
9 Posts
I finally detected the sound problem. The hardware of the head unit is very bad, I tested the audio that enters the CANBUS and this audio leaves without bass, apparently with cut around 200hz. I did the test connecting the cable of the cell phone in CANBUS and the audio is perfect. This Chinese unit has a SUBWOOFER output so I'm manufacturing a mixer for the R and L outputs of the unit and the subwoofer output to get into the canbus. in the tests I did worked.
 

·
Registered
Joined
·
6 Posts
I never specifically checked, however, I have the feeling that the other integration (other than the external amplifier) was working, even after the CANBUS decoder broke.

Could you tell me how your canbus is configured? I can not get it right on mine! as in this image, thank you very much for the attention

Untitled-1.jpg

I need to know the version that is being used and the entry key only, if I can post a photo of this screen I thank you very much
 
1 - 20 of 24 Posts
Top