Veloster Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello,

New to the forums. If i have posted in the wrong section, mods feel free to move or I can repost.

I bought a Hyundai Veloster Turbo SR 2013 about 5 months ago. The cars factory ECU has been tuned for a slight increase in performance along with some other modifications like aftermarket cold intake among other things.

I noticed "very" occasionally I would get a performance issue where with my foot to the floor the car struggled to rev over 4 - 4.5k rpm, even in a low gear, 2nd or 3rd.

I ran a scan with an OBD scanner and it's throwing up error code P0011.

Font Rectangle Screenshot Magenta Electric blue


I jumped on Google and noted some of the various issues that relate to this error.

As a result, the following work has been done -

  • Timing chain was "loose". This was reportedly fixed under warranty.
  • Full service, oil change to rule out oil related issues.
  • Intake solenoid replaced.

If i clear all error codes, the above error always comes back. Sometimes right away, sometimes after a few days.

Performance wise, the car runs fine probably 95% of the time. But I would like to try to get to the bottom of what is causing this error and if it's even something I should be worried about.

Next step I will probably contact the place that did the ECU tuning just to see if changing the default might be causing it to throw up this error but otherwise, mechanics have not really been able to give me a solid answer as to where the issue might lie.

Any help is appreciated.
 

· Registered
Joined
·
1,343 Posts
The code itself is not the problem and you yourself say as much with all the other accompanying problems you proclaim. And questioning whether or not it is the modified ECU is seeming to me you're just wanting justification to keep the things the way they are.
Either learn to live with the problems or get a new ECU, because the one you are using now is what's causing all your problems.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for the reply.

I don't know about trying to justify anything. I'm just wanting to know if it's something i should be concerned about and if the car is operating how it should be.
 
1 - 3 of 3 Posts
Top