Veloster Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey i got a 83k 2015 v turbo full bolt on and tuned never really had much issues until now

every once in a while my car wont start good happened 3 times this week,it cranks solid but doesn’t seem to want to grab and completely start, sounds like maybe its the fuel after like the 3rd or 4th push start it’ll turn on completely but sluggish

i have new coilpacks and plugs never really changed the injectors
Back when i first got the car i used to have issues with the rpms dancing up n down on idle but it went away not sure if that has anything to do with this
Does anybody got an idea on how to fix it

also wanted to know where the injectors we’re located havent seemed to find them
 

·
weekend racer
2014 VT manual
Joined
·
9,470 Posts
need more info on your car, your description doesn't really help ...
 

·
Registered
Joined
·
3 Posts
RPM dancing, and fixed itself. probably just the computer messing around with the right idle speed.

Mechanics tools ie. an OBDII scanner might help. Look up a mechanics trouble shooting checklist tho and try ruling out causes to the symptom.

MAF sensors or something like a thermometer may be malfuncitoning.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
need more info on your car, your description doesn't really help ...
Not much too it it turns on good lately but a few times last week, i had went to turn on the car and it did not want to start, id press the button hear the starter go off and fuel pump go but it just cranks and cranks but wont engage

after 2-3 tries it will finally grab and turn on but it struggled so it did slow sluggish and the rpm guage didnt work stayed at 0
After it finally managed to turn on, i turned it off again and back on then its good like normal

ive have never changed the fuel injectors so i think it could be that but i need to troubleshoot to make sure because injectors are a lil pricey

i have no check engines and I’ve always took care of the car since i got it

it has new oil, new plugs, coilpacks, battery Only 1 year old
And only engine mods are catch can, bov, intake, and the tune. I never had that issue up until recently and ive had all them mods for a while so im thinking something probably took a ****
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
Not much too it it turns on good lately but a few times last week, i had went to turn on the car and it did not want to start, id press the button hear the starter go off and fuel pump go but it just cranks and cranks but wont engage

after 2-3 tries it will finally grab and turn on but it struggled so it did slow sluggish and the rpm guage didnt work stayed at 0
After it finally managed to turn on, i turned it off again and back on then its good like normal

ive have never changed the fuel injectors so i think it could be that but i need to troubleshoot to make sure because injectors are a lil pricey

i have no check engines and I’ve always took care of the car since i got it

it has new oil, new plugs, coilpacks, battery Only 1 year old
And only engine mods are catch can, bov, intake, and the tune. I never had that issue up until recently and ive had all them mods for a while so im thinking something probably took a ****
Down pipe as well
 
1 - 6 of 6 Posts
Top