Veloster Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi all, I have a set of HIDs from Diode Dynamics for my lowbeams. They had been installed for a few months when I started to have trouble with the passenger side not coming on. Upon inspection I found that the bulb had come free. When I checked the drivers side it popped out just from touching it. When I installed them originally I did note that they did not turn as far as the stock blulbs and I guess did not lock into place. So I tried again to get them to turn further and with my hand could not make much progress so I (as gently as possible) used a pair of pliars. I did get more of a turn but not much more and I put as much pressure as I thought was safe.

So long story short I fear they will just wiggle free again. I contacted DD and they sent out some spare parts to work with (I had to pay for them upfront). But right now they have ceased communication with me stating no one else has had any issues and they cannot help me further.


Anyone else had any such fitment issues? If you did can you possibly let me know what you did? Or do I just need to apply more force with pliars?

Thanks!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Just in an effort to be fair DD contacted me today. Support was just wrrapped up the last few days. They have indeed been good to me (and more than once) but have no ideas as to why I am having issues.

If anyone has any words of wisdom I would grestly appreciate it.
 
1 - 2 of 2 Posts
Top