Veloster Forum banner
1 - 10 of 10 Posts

·
Registered
2015 Veloster Turbo
Joined
·
68 Posts
Discussion Starter · #1 ·
I have a 2015 Veloster Turbo. This morning the Climate control knob was working fine. This evening not so much. Number 1 doesn’t work, #2,3,4 will work kind of. I have to turn the knob slightly just before the number for it to turn on, if it’s on the number nothing. Is this a control knob issue, or a blower resistor issue. If it’s a knob issue where can I get a replacement outside Hyundai, or does anyone have a hack to fix it until I can replace it. I live in Ohio, and Mother Nature decided she wants to bring in the cold weather.
 

·
Registered
2015 Veloster Turbo
Joined
·
68 Posts
Discussion Starter · #6 ·
I replaced the blower motor resistor, and it had a scorched mark on it. Wasn’t the issue, still having issue. Looks like one of the resistors on the control knob went bad. If any one has any other ideas before I pay $200 for a new unit let me know.

Thanks
 

·
Registered
Joined
·
2 Posts
I replaced the blower motor resistor, and it had a scorched mark on it. Wasn’t the issue, still having issue. Looks like one of the resistors on the control knob went bad. If any one has any other ideas before I pay $200 for a new unit let me know.

Thanks
It’s the unit it’s self!!! I’m having same issue with my 2012 and it only works on 2 and 3 and shuts off on 1 and 4! I just bought a new unit from oem for 176 that’s with shipping
 

·
Registered
Joined
·
19 Posts
I replaced the blower motor resistor, and it had a scorched mark on it. Wasn’t the issue, still having issue. Looks like one of the resistors on the control knob went bad. If any one has any other ideas before I pay $200 for a new unit let me know.

Thanks
You're just gonna have to BUCK UP and spend the whole $150-$175. And just replace the whole unit! As soon as you fix one problem, you probably created two more just fiddling with it! The unit is "Plug-n-Play", so just replace it.
 
1 - 10 of 10 Posts
Top