Veloster Forum banner
1 - 7 of 7 Posts

·
Registered
2012 NA Veloster
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
It's been about 2 or 3 months already that my cars been throwing the catalytic converter light, but the thing is that it keeps turning on and off. I've been trying to find a pattern but I haven't came up with much other than it usually turns on when I get to a steady highway speed. And I can't figure when it tends to turn off.

The only mods the car has is a K&N CAI and a magnaflow straight through muffler.

I haven't been too worried since it "fixes itself" but I want fix it for real. But I'm not too good with cars in general so I was hoping y'all can help me diagnose it.

Edit: obviously I know it's the converter, but I just find it odd that it's on and off so I thought maybe you guys would happen to know if it's something different.
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
can you give us more info? what is your mileage? what is your maintenance?
 

·
Registered
2012 NA Veloster
Joined
·
4 Posts
Discussion Starter · #3 ·
can you give us more info? what is your mileage? what is your maintenance?
I bought it about a year ago with 67,000 miles and right now it has 76,000. It is my daily so I drive it pretty much every day. I think it was in a fender bender prior to me buying it but nothing major. This is my first mechanical issue. I do change my oil every three months (like I should?). So nothing really wrong with it up until now.
 

·
Administrator
Joined
·
4,656 Posts
Could be that your O2 sensor is going bad.
Do you have any exhaust leaks?
 

·
Registered
2012 NA Veloster
Joined
·
4 Posts
Discussion Starter · #5 ·
Could be that your O2 sensor is going bad.
Do you have any exhaust leaks?
Not that I know of and I don't think I hear a difference unless I've gone deaf to it. Is there a specific way to check for that?

Now that I think about it, I did have a leak by my muffler about 6 months ago and that's a reason why I ended up putting the Magnaflow I have now. I doubt that has anything to do with it though?
 

·
Registered
Joined
·
160 Posts
Mine recently did this and im in a 2012 Standard none turbo. Have Magnaflow Muffler and short K&N intake since 2013.

It was due to a bad or failing gas cap seal or 'O' Ring. I put that blue bearing greas on it real good, closes it and it went away on its own for good. No replacement of said cap.

Eventually I will have to but for now lroblem solved.
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
i have a new oem cap in package i could sell you, lol
 
1 - 7 of 7 Posts
Top