Veloster Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So i am getting the code p2261 on my 2014 Veloster Turbo. I got it checked out and I'm trying to to see if a blow off valve and a recirculation control valve are the same thing in this case. Can any let me know if they are the same or if not whats the difference? thank you !
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
they are not the same, one is a control valve that tells the blow off valve to open.

what is your mileage? chances are your blow off valve is torn, you will have to remove the bumper then the valve to inspect it for tears. if it isn't torn up, then the solenoid is the culprit.
 
  • Like
Reactions: SeaCordSenpai

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
nice what was the resolution to your issue?
 

·
Registered
2013 veloster turbo automatic
Joined
·
11 Posts
Im currently in the same boat. Car is 13 VT automatic 116xxx miles. Threw a p2261 check engine light. So the two options are either the BOV or the recirculation control valve? I saw another thread where someone mentioned how to test if the BOV is going bad or not. Is there where i should start?
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
yup, remove the bov from the intercooler and determine if the valve is cracked or torn underneath it. like i said above. if it is in good shape, then it is most likely the solenoid.
 

·
Registered
2013 veloster turbo automatic
Joined
·
11 Posts
Sounds good i appreciate it. Ill pull it off after work today if it cools down some. The other thread said to just press the diaphragm in and put a finger over the vacuum line and if it diaphragm returns its bad or am i wrong?
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
thats correct, you'll see the tears pretty easily as well.
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
haha yes the OEM unit is a huge piece of crap!

GoFastBits DVX is what I upgraded to after going through 2 of them.
 

·
Registered
2013 veloster turbo automatic
Joined
·
11 Posts
Still having an issue. I replaced the top peice of the BOV (the part i posted a picture of) and the issues still here. No matter the gear. If it goes about 4500rpm its like a light switch and i lose all power. It threw a code i havnt gotten it checked yet. Im going to guess its the same p2261 code id gotten before. Any ideas?
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
did you reconnect the vacuum line? that bov was certainly bad, hoping it is a different code for you.
 

·
weekend racer
2014 VT manual
Joined
·
9,345 Posts
most likely culprit if all the vacuum lines and pipe connections are good.... and the replacement valve was good.
 
1 - 20 of 20 Posts
Top