Veloster Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, so I was just driving my 2016 rally edition and when I went to make a u-turn I noticed a noise that sounded a lot like a super charger. I thought I had some a bad belt squealing like that but when I turned my car back on I noticed smoke pouring out. I popped the hood and noticed coolant everywhere. So I put coolant back in it and turned it on to see if i noticed a leak and I didn't see one. I decided to drive it home, on the way the whining noise stopped but I had 0 boost and no more coolant leaking from the front nor smoke from the exhaust. It ran and idled fine. I'm having it looked at Friday but was hoping yall might give me an idea of what happened in the mean time. Also oil levels where fine and from I could tell didn't have water or metal in it
 

·
Registered
2013 Kia Rio Sedan Auto 1.6 Turbo
Joined
·
56 Posts
Hey guys, so I was just driving my 2016 rally edition and when I went to make a u-turn I noticed a noise that sounded a lot like a super charger. I thought I had some a bad belt squealing like that but when I turned my car back on I noticed smoke pouring out. I popped the hood and noticed coolant everywhere. So I put coolant back in it and turned it on to see if i noticed a leak and I didn't see one. I decided to drive it home, on the way the whining noise stopped but I had 0 boost and no more coolant leaking from the front nor smoke from the exhaust. It ran and idled fine. I'm having it looked at Friday but was hoping yall might give me an idea of what happened in the mean time. Also oil levels where fine and from I could tell didn't have water or metal in it
"noticed coolant everywhere" please elaborate
 
1 - 2 of 2 Posts
Top