Veloster Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I am new here. So any info you have it is more than appreciated. I purchased a 2013 veloster a couple months ago. My blower will shut off when it is on high. I am lost as for the cause of it. Please help
 

·
Registered
07 WRX, 12 Veloster NA, 71&70 VW Type 3 Fastback, 2011 TDI Sportwagen
Joined
·
511 Posts
Check the variable thermresistor in the main housing. That's usually a sign that one of the resistors blew.

Part i'm talking about
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Thank you for your quick reply. I have had them go out before and it was usually the other way around like low not working. But never turning off on high. It will turn back on after a few minutes. So I was lost
 

·
Registered
07 WRX, 12 Veloster NA, 71&70 VW Type 3 Fastback, 2011 TDI Sportwagen
Joined
·
511 Posts
It depends on the car, my wife's 98 ford escort would default to high on all settings when blown but my rx7 would default to low. Should be very visible when checking it if it's blown.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
After further investigation turns out on the veloster the l.e.d. light for the a.c. melts the connector on the daily. Which the resistor is on back of the daily. So without your help I would have never checked it. Thank you so much.
 

·
Registered
Joined
·
24 Posts
After further investigation turns out on the veloster the l.e.d. light for the a.c. melts the connector on the daily. Which the resistor is on back of the daily. So without your help I would have never checked it. Thank you so much.
If the problem is the blower speed dial I believe there is a technical bulletin on an issue with them failing. This was determined long ago. You may want to check with Hyundai and see if they will replace it at no cost. No guarantees but worth asking. Let us know what happens!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
I replaced the climate control. That was not the problem the connector to the switch was melted. Now I have to find one of those.
 

·
Registered
Joined
·
24 Posts
I replaced the climate control. That was not the problem the connector to the switch was melted. Now I have to find one of those.
So you already bought a replacement climate control knob assembly? I would still check with Hyundai, especially if the connector melted. They may have a replacement connector for it since it may have been a part of the technical bulletin procedure for the service department. Just an idea to save you from hunting for one at a junk yard. Good luck brother!

Also if you bought it used, you can ask the seller to cut it off his car and sell it to you. Another idea! TC
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Thanks and I will check with Hyundai. That would be awesome if they did replace it.
Were can I find the forum?
 

·
Registered
Joined
·
24 Posts
  • Like
Reactions: misnblu
1 - 12 of 12 Posts
Top