Veloster Forum banner

1 - 19 of 19 Posts

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #1
Anyone want to help a noob with a key fob issue? Replaced fob battery, even tried the whole trick start with pushing the fob up to the start button, replaced fuses...and still nothing...
I did also buy a brand new battery for the car two weeks ago.
I didn't think having a button to start the car, with a fob, would cause so much drama
-_-
? What kind of puzzle did I get myself into?
Lol I appreciate any help ????
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #3
Yes, before I replaced the battery on the fob, I tried the pushing fob on the start engine button, and it only took me to acc mode, didn't start my car...
It did say on the trip indicator screen to turn on fuse, and it was on..
I then tried the pushing fob to button trick again today, with no success, before walking to AutoZone for batteries and fuses.
Replaced fob battery, lamp fuses, fob key fuses, and got nothing...I'm lost
(This is my first button start car...and I'm so confused lol)
 

·
Registered
Joined
·
560 Posts
Technically, that's a "smart key" not a "fob". A fob just lock and unlocks the car, a smart key does what a fob does and also is the electronic key to start the car. Does the smart key lock and unlock the car? Does the little light on the smart key light up when you press the buttons?

Your car should have come with 2 smart keys. Do you have the other one? Does it start with that key?

If you don't have another smart key to try, I'd check the battery is good and installed correctly.
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #5
I'm new to the smart key thing. Used to having old cars. This is my first one with the button to start.

I have two keys and both didn't work, I replaced both with batteries, bc both weren't lighting up when I pressed buttons.

Can't get into car without manually using the actual key, and car won't power on.

I've searched for videos and asked around and this is my last step.

Any help is appreciated (sorry I'm not good with terminology lol)
 

·
Registered
Joined
·
560 Posts
I just re-read your post and saw that you replaced the car battery. Are the cables on the car battery tight?

Also, is the car in park and your foot on the brake? Maybe the brake switch is bad or the switch in the shifter is mis-aligned causing the car to think its not in park or your foot isn't on the brake. Do the brake lights work? Try putting the car in neutral and trying to start it.
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #7
Now that I replaced batteries on smart keys they are both lighting up but car won't recognize either...
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #10
I just re-read your post and saw that you replaced the car battery. Are the cables on the car battery tight?

Also, is the car in park and your foot on the brake? Maybe the brake switch is bad or the switch in the shifter is mis-aligned causing the car to think its not in park or your foot isn't on the brake. Do the brake lights work? Try putting the car in neutral and trying to start it.
I'm going to go try and I'll let you know what happens! ??
 

·
Registered
Joined
·
560 Posts
If the battery cables aren't the issue, next thing I would check is the SHUNT (memory) fuse. It's in the inside fusebox and its usually yellow and it need to be pulled out and pushed back in all the way.
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #13
Maybe it's the battery cables that are loose. Check to make sure they are tight and the battery has more than 12.0 volts.
Out in my car break lights aren't going on. I have both smart keys, both lighting up when I press them, car is not responding.
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #14
If the battery cables aren't the issue, next thing I would check is the SHUNT (memory) fuse. It's in the inside fusebox and its usually yellow and it need to be pulled out and pushed back in all the way.
Ya no luck with that ??‍♀
I also found a tool left under my hood, from the person who put my battery in. I'm pissed. I hope it's nothing crazy. ?
 

·
Registered
Joined
·
560 Posts
Out in my car break lights aren't going on. I have both smart keys, both lighting up when I press them, car is not responding.
If the brake lights aren't working then the switch is probably bad and that's why the car wont start. The computer uses the switch to know if your foot is on the brake or not.

However, I'd check the brake light fuses and the SHUNT fuse too.
 

·
Registered
2015 Veloster turbo
Joined
·
11 Posts
Discussion Starter #17
I checked those fuses and ya I hope that's not it but probably more of what the issue is.
Shitty time to have to take my car in -___-
Thanks for the help! I'll have a mechanic come by tomorrow, if they're available.
Much appreciated ??????
 
1 - 19 of 19 Posts
Top