Veloster Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I drive a 2019 Turbo and I’ve been having issues with my left hand turn signal. Usually when it rains or is really humid, the signal doesn’t work at all. Bulbs are good and it doesn’t even turn on inside the cabin. I’m sure it’s a bad fuse or switch, but I’m not great with electrical issues. Wondering if anyone else has had this issue?
 

· weekend racer
2014 VT manual
Joined
·
9,836 Posts
Maybe the stalk itself ?
 

· Registered
Joined
·
8 Posts
I also had a problem with my left front turn signal, after I installed led bulbs. I put the stock bulbs back in. Left front still didn't work. I put the right bulb and socket, in the left side and it worked. Ordered a new bulb socket. Problem fixed. Using regular bulbs.
 

· Registered
Joined
·
3 Posts
I drive a 2019 Turbo and I’ve been having issues with my left hand turn signal. Usually when it rains or is really humid, the signal doesn’t work at all. Bulbs are good and it doesn’t even turn on inside the cabin. I’m sure it’s a bad fuse or switch, but I’m not great with electrical issues. Wondering if anyone else has had this issue?
Im having the same problem what was the issue
 

· Registered
Joined
·
1,343 Posts
Mine was the junction box. It took over a month of testing and diagnostics and replacing parts to figure it out. Hope that helps.
Can you post more information on the "Junction Box". The shop paperwork should have part numbers and other info. This is information that would be significant for others who experience similar problems.
:)
 

· Registered
Joined
·
5 Posts
Can you post more information on the "Junction Box". The shop paperwork should have part numbers and other info. This is information that would be significant for others who experience similar problems. :)
I’ll take a look. I don’t think I actually got my paperwork (long story short I picked up the vehicle had it for a few weeks to test the problem and then was tboned so never went back to get it from them). My cars been out of commission waiting on repairs since lol. That said, I’ll try and email the dealer to see if they can send me a copy.
In the weeks I had it I didn’t have the problem again, and it was pretty regular for me so it definitely fixed it.
Will get back to you when I get updated!
 
1 - 12 of 12 Posts
Top