Veloster Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Good afternoon, I just recently purchased a 2015 Veloster Reflex for my son. There were a few issues with it, one being the drivers side window stick when going up and the radio didn't have sound. I was able to find a blown amp fuse for the radio and fixed that, and removed the door panel and greased the window track and was able to get that working UNTIL I put the panel back on, then the problem reoccurred. I'm assuming that is possibly from the panel being too tight, but not sure.

So yesterday he went out to drive the car and he came in and said the AC wasn't working. I went out and started the car and noticed right away that it idles higher than normal and the ac was indeed not blowing. I then realized the power steering wasn't working either. I shut the car off and looked under the hood thinking maybe the belt or something was coming off or wasn't secured. It all looked fine. I tried to start the car again and it would only click. I thought the batter was dead so I went and purchased another one, installed it and the same problems continued.

I then checked all the fuses in both the engine compartment and under the dash and found that the 125v multipurpose fuse had two blown inside it. So I've ordered a new fuse. The car isn't throwing any codes, I verified by hooking up my scan tool. So I'm not sure where to go from here. Do I just install a new fuse and hope for the best, or is there a better way to diagnose this problem?

Looks like the ALT and DCT fuses are what blew inside the multi fuse.

Thanks in advance and sorry for the long first post.
 

·
weekend racer
2014 VT manual
Joined
·
9,470 Posts
your post is informative so that helps alot!

what age was the old battery? how do the grounds look? these two things will be the first to check... there is no power steering belt it's electric driven in the steering column.

not really many posts here on the big fuses blowing, any chance there were signs of an aftermarket radio or speakers installed?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
The old batter had 10/21 on it. But I went ahead and bought a new one, but the new one was 12/21 and they didn't have anything newer. Everything looked good on it. When I was looking into the radio issue, I pulled it and there doesn't appear to have been anything aftermarket on the car. Stock speakers, no splicing, etc.

The fuses that blown were for the DCT and the TCM, so I'm assuming this is transmission related and the other issues are just because that entire fuse has crapped out since the ALT/DCT fuse is in the middle and connects the two sides and it blew.

I just had the car towed to the closest Hyundai dealership. I'm hoping it's nothing major, he really likes this car, but I'm ready to get rid of it and buy him a new kia or something on the low end just to have the warranty. That was my original plan, yet he fell in love with this one.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Update

No cause of the blown fuse was found, but it was the cause of all the issues he was having. We drove the car around yesterday and so far haven't had any other issues. They are thinking the old battery caused the issue or that lightning hit near by it and arced to it blowing the fuse. Neither can obviously be confirmed so we'll keep our fingers crossed and hope it doesn't happen again.
 
1 - 4 of 4 Posts
Top