Veloster Forum banner

1 - 5 of 5 Posts

·
Registered
2013 VT stock
Joined
·
1 Posts
Discussion Starter #1
Hey new here and just getting into fixing cars with the help of a friend. My 2013 VT started to not start and just click a couple weeks ago and replaced the starter, alternator, and battery to no avail. No codes getting thrown or anything any suggestions? Looking at taking to a mechanic in the next day or two.
 

·
Registered
2012 Veloster NA, 71 VW Type 3 Fastback, 70 VW type 3 Fastback, 2011 TDI Sportwagen, 99 impreza
Joined
·
308 Posts
Check your grounds for corrosion and reseat the battery cables to start if there's no codes. I had a no start condition after replacing my battery which ended up being a loose bottomed out terminal clamp (i shimmed mine)

Another thing to check would be pulling the starter and verify it attempts to work out of the bellhousing (ie. Not a DOA part)
 

·
Registered
Joined
·
940 Posts
Hey new here and just getting into fixing cars with the help of a friend. My 2013 VT started to not start and just click a couple weeks ago and replaced the starter, alternator, and battery to no avail. No codes getting thrown or anything any suggestions? Looking at taking to a mechanic in the next day or two.
You might let us know what's happening now after you replaced all that stuff. I mean, is it still just clicking? We'll all take it for granted that it's still not starting, so you don't have to repeat that part.
 

·
Registered
Joined
·
76 Posts
Clicking sound would be the started working as it should but if your not getting a *rrrr rrrr rrrr sound with it then the plugs arent firing. I would pull the packs and have someone try starting it with the plug out but attached to the pack and look for spark one each one. If the plugs have a burnt orange around the ceramic part they are probably bad so replace. If you are getting spark but the engine doesnt try to turn over but hear the clicking sounds then it maybe. Fuel delivery issue.
 
1 - 5 of 5 Posts
Top