Veloster Forum banner

21 - 25 of 25 Posts

Registered
Joined
1 Posts
Did you fix your problem? I got the same problem, I went to the Hyundai and they didn鈥檛 find the problem and today I was drive on 95 ( freeway) the car lost power , o changed to the sport mode , and the gear indicator disappeared. I stoped . Turn off and on the back to the normal .
 

Registered
Joined
4 Posts
I鈥檓 having the exact same issue on mine, the dealership has replaced the transmission three times now and claimed it was fixed, went to go drive it to get tires and it won鈥檛 catch when I put it in gear. Restarted it and tried it again a few times and nothing. Came back an hour later and it catches but makes a fairly loud clank when you start to hit the gas initially.
Would appreciate knowing your outcome with this. I am having same problems but in a standard. Still, be interested in knowing what you find out.
Thanks
John
 

weekend racer
2014 VT manual
Joined
8,476 Posts
Would appreciate knowing your outcome with this. I am having same problems but in a standard. Still, be interested in knowing what you find out.
Thanks
John
considering you have a standard you should probably start a new thread. This is about the DCT.
 

Registered
Joined
1 Posts
I have a 2012 Veloster. This morning when I went out to leave for work, I was able to back just out of the driveway but then I couldn't go anymore backwards or forwards. The engine would rev but no gear would engage. I shot the car off, came inside to get my daughter to see if we could push it out of the way. She said it had happened before and to let her look at it. She started it up and moved it. I figured what ever that problem was it reset itself when I turned the car off and she turned it back on. Guessing it was electrical or electronic or something.
Could this also be the GATE SHIFT ACTUATOR?
I have the same problem, it just started ,did you ever find out what it was ?
 
21 - 25 of 25 Posts
Top