1. Welcome to Veloster Forum: Hyundai Veloster / Veloster Turbo Forums – General discussion forum for Hyundai Veloster

     
Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By ImAlwaysMIA
  • 1 Post By lil_buddy
  • 1 Post By patshotrods

Thread: "2019 Hyundai Veloster 2.0L Issue"...

  1. #1
    Junior Member patshotrods's Avatar
    Join Date
    Feb 2019
    Location
    Danville, VA. 24540
    Posts
    14

    Question "2019 Hyundai Veloster 2.0L Issue"...

    I have a 2019 Hyundai Veloster 2.0L that I bought new about 6 months ago, I have 900 miles on it as of now. When I left work yesterday evening after cranking up my car the instrument cluster did not light up nor did anything on it work, I cut the car back off then back on with the same issue, I got down the road about a half a mile and everything started working again but the check engine light was on. I got home and cut the car off then back on and everything was working fine just the check engine light was still on. I will check it on Monday when I go back to work. Very strange! If anyone can shed any light on this please do.

    Please advise...

    Thanks for your help,


    Pat - 2019 Hyundai Veloster 2.0 Auto

  2. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  3. #2
    Junior Member ImAlwaysMIA's Avatar
    Join Date
    Nov 2018
    Location
    Chicago, IL
    Posts
    20
    If you have a CEL then the car's computer has a code. First step would be to find out what that code is. Most auto parts store will read and tell you what that code is for free, so I'd start there if I were you.
    nvyseal likes this.

  4. #3
    Junior Member patshotrods's Avatar
    Join Date
    Feb 2019
    Location
    Danville, VA. 24540
    Posts
    14
    Thanks ImAlwaysMIA! I work for Advance Auto Parts so I am going to check the code with the OBDII Scanner tomorrow. I will post my findings.


    Pat - 2019 Hyundai Veloster 2.0 Auto

  5. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  6. #4
    Member
    Join Date
    Dec 2018
    Posts
    42
    avail yourself of the fine warranty you paid for
    oni888 likes this.

  7. #5
    Junior Member patshotrods's Avatar
    Join Date
    Feb 2019
    Location
    Danville, VA. 24540
    Posts
    14
    lil_buddy, Thanks and I hear ya!


    oni888 likes this.
    Pat - 2019 Hyundai Veloster 2.0 Auto

  8. #6
    Junior Member patshotrods's Avatar
    Join Date
    Feb 2019
    Location
    Danville, VA. 24540
    Posts
    14
    I scanned it at work today and it showed one code; Error Code P0462 is defined as Fuel level Sensor Circuit Low Input, which means the fuel level sensor is no longer taking correct readings. When the instrument cluster was out for that short period of time and the fuel gauge was not working it caused the light to come on and this code was generated. Everything worked fine all day today so hopefully this was just a fluke, I erased the code and re-set everything and the light went out. Finger crossed!

    Thanks,

    Pat - 2019 Hyundai Veloster 2.0 Auto

  9. #7
    Junior Member
    Join Date
    Dec 2018
    Posts
    4
    Why wouldn't u just take it to the dealership im assuming u payed for a warranty and holy cow 900 miles in 6 months ive owned my 2019 ultimate turbo for 3 months and have put 7500 miles on it with no issues

    Quote Originally Posted by patshotrods View Post
    I have a 2019 Hyundai Veloster 2.0L that I bought new about 6 months ago, I have 900 miles on it as of now. When I left work yesterday evening after cranking up my car the instrument cluster did not light up nor did anything on it work, I cut the car back off then back on with the same issue, I got down the road about a half a mile and everything started working again but the check engine light was on. I got home and cut the car off then back on and everything was working fine just the check engine light was still on. I will check it on Monday when I go back to work. Very strange! If anyone can shed any light on this please do.

    Please advise...

    Thanks for your help,


    <img src="https://www.veloster.org/forum/images/smilies/confused.png" border="0" alt="" title="confused" class="inlineimg" />

  10. #8
    Junior Member
    Join Date
    May 2019
    Location
    ravenna ohio
    Posts
    13
    i hope you realize by "resetting" the CEL you cleared all of your readiness indicators and learning the ECM did too. a problem if you are due for an inspection. it will take some time to get them back to where they should be. if what you believed caused the CEL to come on, it would have went off on its own after a couple or three drive cycles. if not, avail yourself of the warranty and dont screw with it.

  11. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2