1. Welcome to Veloster Forum: Hyundai Veloster / Veloster Turbo Forums – General discussion forum for Hyundai Veloster

     
Results 1 to 4 of 4

Thread: 2013 Veloster Turbo Not starting after 20-30 minute drive

  1. #1
    Junior Member
    Join Date
    Jul 2019
    Posts
    2

    2013 Veloster Turbo Not starting after 20-30 minute drive

    OK. So what is happening. I start the car and there is no problem. I then will drive 20-30 minutes to go someplace...i.e home depot. Its hot outside, mid to upper 80s.
    When I get back to my car to start, it just cranks and wont start at all. If I wait 30-40 minutes for what I believe is an engine cool down, the car will finally start right back up. No problem at all.

    This issue persists right now, but I have noticed another issue recently. The car will sputter a little bit at higher speeds after 10 minutes of driving.

    Any Ideas on what could be causing this?

  2. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  3. #2
    Senior Member Ricky-D's Avatar
    Join Date
    Feb 2013
    Location
    SC Midlands
    Posts
    576
    First off I suggest you invest in a OBDll reader and get the torque app which will show any problem you may be encountering with you engine.

    You can set the app to diagnostic so it will show you if any problem has been recorded, or detected while your car is running.

    Also, I suggest to start using a different fuel from what you are presently using. A better grade would be preferable and non-ethanol would be even better. Definitely change where you fuel up.

    Not much sense in going anywhere else until you get the reader and observe and report the results.

    You might want to indicate the mileage on you VT and transmission type and any maintenance issues or not. How long you've had it too, and the mileage you've put on it. And your driving style also.

    ***
    2013 IRONMAN SILVER VT-AT ULTIMATE

  4. #3
    Junior Member
    Join Date
    Jul 2019
    Posts
    2
    Its 2013 Turbo Automatic. Just busted 100K. In Feb of this year was the last service. Coils were replaced and the Injectors were flushed. Is this a fuel pump issue? Some Sensor Issue?
    I'm about ready to fill up again. I'll look to try premium at another gas station and see if that has any impact.

  5. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  6. #4
    Super Moderator nvyseal's Avatar
    Join Date
    Jul 2012
    Location
    So Cal. I. Empire
    Posts
    4,175
    Crank position sensor
    Ultimate Elite White VT A/T • Window Tint: 35% Front 30% Back • Vogue Signature V Tires • OEM Mudguards • Short Ram Intake • Pierce Motorsports VT-ONE Series Chromoly Strutbrace • Magnaflow Catback Exhaust • Turbosocks FMIC • ADD1 BOV BTRcc Custom Tune

    밥솥

  7. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2