NEWS
 

  1. Welcome to Veloster Forum: Hyundai Veloster / Veloster Turbo Forums – General discussion forum for Hyundai Veloster

     
+ Reply to Thread
Results 1 to 13 of 13
Like Tree3Likes
  • 1 Post By BMJM12
  • 1 Post By 1.6 T-GDI
  • 1 Post By silver-v

Thread: Battery Completely Dead Then Back To Life Next Day...and other issues

  1. #1
    Junior Member
    Join Date
    Mar 2012
    Posts
    5

    Unhappy Battery Completely Dead Then Back To Life Next Day...and other issues

    I bought my 2012 Veloster Auto/Dual Clutch in Rome, Ga in Jan.
    Overall I really like my car and its really cute, but I’ve had some issues that have really upset me.
    After about a month of ownership…
    I get off work at midnight and go out to my car and it is dead. Completely dead. The keyfob won’t unlock the doors, so I manually unlock them, no lights, no sounds and obviously won’t crank. So, my boss jumps it for me and we check to make sure the alternator is charging it and the meter says that is fine. So, I decide to drive home and call Blue Link. I get in the car and it says that all the doors are ajar and the interior lights won’t go off. So, after double checking all the doors and hatch I drive home with the lights on and call Blue Link. They say that all they can do is have it towed. Well, its midnight and I’m an hour from the dealership so I think that wouldn’t help. So, I drive it around for a while to charge some and then go home. I pull in the driveway and when I turn it off and lock the doors it sounds lifeless again. (except for the interior lights that won’t go off) Tired and frustrated I leave it for the night.
    The next morning I call the dealership. After waiting around I decide to just get it to start up and drive it down there. I go out to the car and it cranks right up like nothing ever happened. So, I drive it to the dealership and tell them what happened. They run tests on it for hours and tell me that they can’t loan me a car or give me a rental even if they have to keep it overnight! I’m furious about this so I wait. They don’t find anything wrong with it. So, they proceed to tell me that I must have left a light on or something plugged in. I don’t plug anything into my car and the lights all go off automatically for this reason and besides I didn’t have any interior lights on when I drove to work-it was daylight. Anyhow, they continue to insist this. So, I have them wash the car for me at least because I’m furious. They give me the paperwork and tell me if it happens again to not try to start it but to have it towed and they will then be able to tell whats wrong with it-like I did something wrong. Towed? At midnight? When they are closed and I’m an hour away and will be left without a car? Are you kidding? Hello! Its not my fault my car was dead when I got off work at midnight! They then insist that I be careful not to leave any interior lights on like I’m a child. I’m furious, but I leave and hope that this is just a fluke.
    So now its about a month later and the yellow “engine malfunction” light is on. I don’t know what this could mean and haven’t had any other messages come up. I haven’t called blue link yet, because I figured all they’d say is they can tow it, but I might call them and see if they can pull up any messages since I’ve seen some other posts in here that look like they should be able to tell what the malfunction is. I’m going to have to take off work again and take it in Monday and I’ll update this post. I’m really unhappy about it. If they don’t give me a rental car I’ll probably call Hyundai and may just call them anyway. I bought a new car so that I wouldn’t have these kinds of issues, because my old car kept breaking down and now I have the same problems and keep having to miss work because of a car.
    Has anyone else had issues like this? The random dead battery really concerned me, especially since it seemed like a possible electronic issue.
    (Side Note: This is also the reason I didn’t do the automated survey when they called over and over again a week or two after the purchase. I’d like for them to call me now to see my “satisfaction.” )

  2. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  3. #2
    Senior Member GreyGhost12's Avatar
    Join Date
    Dec 2011
    Location
    Northeastern NY
    Posts
    2,763
    It almost sounds like a lose ground. Perhaps you should have that checked out and see if it's the culprit.

  4. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    5
    Thanks. I thought so too. I told them I thought something could be loose telling the car that the battery was dead when it actually wasn't. I was trying to think of all possibilities, despite the fact when we checked it with a meter the battery was drained. They said they checked everything out. They kind of looked at my car like it was a space ship though, so I don't really know how educated they are on these cars yet. I'm hoping they've learned something in this past month...

  5. #4
    Senior Member
    Join Date
    Feb 2012
    Location
    Palm Bay FL
    Posts
    462
    The yellow check engine light usually means there is an issue with the emissions control systems. I've had it happen twice now, with no actual problem to be found. Hyundai is aware of this problem, read this thread for a little more info. When you call BlueLink, they will run a diagnostics check on the car, to verify the CEL. Ask them what code the test is showing, it will be like P0456 or something similarly formatted. That way we can tell what the code is, maybe you're having the evap leak, small/very small issue some of us are also having.

    Usually, and I stress that word, an emissions fault that sets a solid CEL wouldn't be related to an entire electrical system failure. In fact, it's usually safe to drive on a solid 'check engine light' until you can get the car in to be looked at. So I wouldn't worry about being towed over the CEL light, unless it is happening in conjunction with another total electrical failure. A flashing CEL is usually a sign that something serious has happened with the engine management, and driving further could cause severe damage to the vehicle (or an unsafe driving condition for you.) In that case you would definitely want it towed.

    If your current dealer isn't making you feel confident in their abilities, let them know. It's understandable to ask basic end-user trouble questions, like 'did you leave a light on or something plugged in,' but when you answer with surety that such wasn't the case, they should start to at least consider other possibilities. Of course, and we discussed this elsewhere, how could leaving something plugged in kill the battery when the outlets are without power when the car is off?

    Keep us up to date on what happens, it may help someone else get to the root of a similar problem in the future. I hope it gets sorted out for you ASAP.

  6. #5
    Junior Member
    Join Date
    Mar 2012
    Posts
    5
    Thanks! I called Blue Link they said everything is green on their end. I'm scheduled to have it checked Monday.

    To add... I've been reading all the posts from other people and realized there may even be other things wrong. I have got the "Check Module" message at least 4 or 5 times where my xm stops working and I have to turn it off to reset it. Also, the variable sound where its supposed to get louder or softer depending on your speed does not work either. I overlooked these things because well, I went from basic radio complete with a good ol' tape deck to this, so I didn't know if it was something to worry about. I know the sound change shouldn't be extremely noticeable, but it should change like its supposed to. After reading the other posts I will bring this up on Monday as well.

    The car seems to really struggle to change gears going over small mountains and hills. I brought this up in a different post. I take the eco off before going over any kind of mountain, but its like it strains itself in one gear then finally jumps into another. This hardly seems normal or good for the car.

    Maybe Hyundai birthed the Veloster prematurely?
    VelosterLady likes this.

  7. #6
    Senior Member
    Join Date
    Feb 2012
    Location
    Palm Bay FL
    Posts
    462
    I've noticed that as I'm getting more miles on it, just around 3k now, it has been shifting much smoother vs. when it was brand new. It may not have 'learned' your habits yet.

    I have not tried the variable volume yet, but on other cars I have owned, it was usually obvious when it would kick in if I had it set for louder/higher compensation and opened the window while sitting still. If you are having problems with the audio system and the odd dead battery/no power problem, I don't think that it's out of the question they may be related. Maybe not, but the way the important systems are tied together, it would be something I'd at least consider.

    I don't know if it's a case of the car being released too soon as much as there being some 9not unexpected) common first-year problems AND the occasional serious defect elsewhere.

  8. #7
    Junior Member
    Join Date
    Mar 2012
    Posts
    5
    Okay, I'm updating on my "service" trip. Well, I'm not too disappointed, it was about what I expected from them. I take my car to the dealership and they don't even call me when its finished. I have to call them to ask about it four and a half hours later and here's what their story is.

    The engine malfunction light was due to the gas cap. They asked if I had reset the gas cap already. When I said yes I did Friday they said, well it sometimes takes it a while to reset... Friday, Saturday, Sunday, Monday..... 4 days. Really?. ...is this true, everyone I've asked says thats absolutely ridiculous.

    I asked them about the radio variance. They said that they called and spoke with someone at hyundai about it and that it will change very minimally adjusting as you speed up or down. When I asked why it doesn't change at all they said again that it is made to slightly change and the subject was changed.

    Then, about the fact that my radio will sometimes come up with "check module" and the radio signal go out was the icing on the cake. They ask me if I have a separate gps system that I use in the car. I told them no. They ask, “Well what is the chord that you have in your car for then?” I tell them that went to an old device that doesn't work and I don't use it in my car. It is there because I sold my other car and it was in it at the time. Besides, why are you going through my stuff and asking me about a chord? So, they tell me that Hyundai says that sometimes when you hook up another device it has been known to mess with the radio. This is ridiculous.

    So, I go down there and end up telling them that I'm completely unhappy. I have to waste my time coming there for them to tell me that nothing is wrong, avoid things and then blame me for things going wrong with their product. I ask, "So, are you telling me I'm not supposed to plug anything into the usb device that was sold to me built into the car and was one of the things they were so proud of when selling it?" They kept telling me no, they weren't saying I couldn't plug something in, but that it has been known to mess with the radio. So I say, "Well, then you need to fix your radio Hyundai." Don't tell your customer not to plug something in. Okay and besides, I don't use that device, its broken. I don't plug that into my car, so this isn't the reason for the message. Do I get any kind of feedback as to another reason why this could happen. No. What did I expect though?

    I'm furious and fed up with them which will probably not help as I know I'll be back with more issues. I'm not expecting them to ever get better. I told them the next time this happens they will have to actually do something, fix or change something, but I'm just so sick of it already. Maybe I'm overreacting, but the point of a new car is low maintenance, not having to take it to the shop once every month or every other month. The fact that they blame me for things and act clueless doesn't help. I’d like to at least know what is going on and it not just be like it’s a “false alarm” every time. I don’t think it’s really possible that nothing is going on with this car. I think there is some kind of electrical issue.

  9. #8
    Senior Member Dezoris's Avatar
    Join Date
    Aug 2011
    Posts
    1,393
    I can only respond to the "check module" issue with XM. This is almost always due to a problem with the headunit starting and not communicating or initializing the XM module and unlocking the GPS.
    If you reset the unit while driving does it work? The dealer has no troubleshooting methods for this all they can do is replace the entire head unit. Which is what they should do if this is a constant issue. Your auto volume control wont work if you are getting the check module error as it relies on GPS/OBDII data. Again this would be fixed if they replaced the head unit.

    Order of Replacement
    1. Head Unit

    If does not fix
    2. Shark Fin Antenna.
    2012 Marathon Blue Veloster | 2007 Lotus Exige S | 2010 Honda Fit
    Veloster Interface Design | Development Website | Full Veloster Review

  10. #9
    Senior Member lobo302's Avatar
    Join Date
    Oct 2011
    Location
    moline ohio
    Posts
    872
    The engine malfunction light was due to the gas cap. They asked if I had reset the gas cap already. When I said yes I did Friday they said, well it sometimes takes it a while to reset... Friday, Saturday, Sunday, Monday..... 4 days. Really?. ...is this true, everyone I've asked says thats absolutely ridiculous.

    There is a reset for this????

    I have had this trouble with my old neon.Found out the first time that the cap was not put on tight enough,the second time the cap was broke.I feel for you,stay on them and don't let them have an inch.If they still want to blame you ask for the sevice manager & owner,and make sure Hyundai know about all of this and make sure you keep ALL PAPER WORK ,you may need this later down the road.
    2012 Silver Ironman Style w/ DCT Born Aug. 27,2011
    Tint windows. 50 % all around

    I will give the R-Spec Turbo a very long look seeing that my lease is up in about 6 months.
    Sometime you take a chance on something and it rewards you with things you never thought of.
    Bought my Veloster from Brandon Garvin @ Taylor Hyundai and will buy my next from him.........
    Just added a Tucson Limited AWD and couldn't be happer ....... July 20,2013

  11. #10
    Senior Member 1.6 T-GDI's Avatar
    Join Date
    Jun 2011
    Location
    Tampa, FL
    Posts
    2,552
    Keep ALL your paperwork.
    VelosterLady likes this.
    2013 Veloster Turbo | Matte Gray | Ultimate Package

  12. #11
    Junior Member
    Join Date
    Jan 2014
    Location
    Alberta
    Posts
    6
    I'm in Canada and am having the same problem. I placed a multi meter inline with the battery to measure the current draw and noticed an issue right away!

    The Veloster had all doors closed and all accessories off and the meter showed 1.48amp's of draw! I called the dealer and told them about the issue and that many people are having the same issue, and this is the first time they've heard of it. They said the current draw from the V is supposed to be 0.2amps.

    I worked for an hour in my shop removing fuses and continued to watch the meter, and then I found it! The issue for my V is the multimedia system. I removed the in cabin multimedia fuse and the draw turned to 0.19amp!

    I called the dealer back and they thanked me for trouble shooting the issue, and I scheduled an appointment to get in serviced.

    I hope they get it this time.

    My appointment is on Monday, and will update people when I know more.
    VelosterLady likes this.

  13. #12
    Junior Member
    Join Date
    Jan 2014
    Location
    Alberta
    Posts
    6
    So I had to reschedule my appointment for the car. Its rescheduled for 28 Jan 14. And it died again! Drove to work and went to start the car at the end of the day and NOTHING :/

    Really starting to piss me off!

  14. #13
    Senior Member VelosterLady's Avatar
    Join Date
    Nov 2012
    Location
    Western Massachusetts USA
    Posts
    637
    Quote Originally Posted by silver-v View Post
    So I had to reschedule my appointment for the car. Its rescheduled for 28 Jan 14. And it died again! Drove to work and went to start the car at the end of the day and NOTHING :/

    Really starting to piss me off!
    Get a copy of EVERY single service record generated for every visit to the dealership for your car.
    That was KEY to get my Veloster replaced as a Lemon. I cannot stress this enough to anyone having problems, ALWAYS get a copy of your service record every single visit to the dealership even if the problem isn't resolved make them print you out proof of the visit!!
    Former cars:
    2013 Veloster Boston Red
    ext, black & gray int. 6spd M/T(Christine the evil demon car)
    Replaced 11/2013 with a black 2013 Elantra GT 6spd M/T Style & Tech, Loaded with every possible option. (Demon car part 2)
    Current Vehicle since June 2014, Happily driving trouble free a brand new 2014 Honda CR-V EX-L AWD with Navi in Mountain Air Metallic
    33.8MPG for an AWD with no trips to the shop, yep I'm a happy gal

  15. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

Similar Threads

  1. !! Battery Discharge Warning !!
    By V-5.0 in forum Hyundai Veloster Audio and Electronics
    Replies: 16
    Last Post: 09-26-2013, 08:46 PM
  2. Replies: 5
    Last Post: 03-14-2012, 04:07 PM
  3. Kim Jong Il Dead
    By jiminee in forum Off Topic Discussion
    Replies: 8
    Last Post: 02-01-2012, 12:58 PM
  4. I have no life and need to get back to work....
    By pickviper in forum Hyundai Veloster General Discussion
    Replies: 14
    Last Post: 12-29-2011, 02:34 PM
  5. If the battery is dead...how d'you bump start?
    By Sak in forum Hyundai Veloster Engine and Transmission
    Replies: 4
    Last Post: 09-11-2011, 09:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2