NEWS
 

  1. Welcome to Veloster Forum: Hyundai Veloster / Veloster Turbo Forums General discussion forum for Hyundai Veloster

     
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 20 of 34
Like Tree1Likes

Thread: Galaxy S3 and bluetooth

  1. #1
    Member
    Join Date
    Aug 2012
    Posts
    53

    Galaxy S3 and bluetooth

    I have a VT with nav and I'm unable to get the song info to show up when using bluetooth (or with the aux cable for that matter) with my S3. Has anyone been able to get the song titles to show up with their S3 ? The controls seem to work just not the display.

  2. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

  3. #2
    Senior Member kimtyson's Avatar
    Join Date
    Jul 2012
    Location
    York, Pa
    Posts
    789
    I'm pretty sure that you can't get the album info or song info using BT. Seems we are lucky to get it to play but that's about it.

  4. #3
    Member
    Join Date
    Apr 2012
    Posts
    62
    Hi..I use a Samsung Galaxy Note and on the display appears the name of the song...

    Sent from my GT-N7000 using AutoGuide.Com Free App

  5. #4
    Member
    Join Date
    Aug 2012
    Posts
    53
    Has anyone been able to use the car's USB with their S3 ? When I plug my phone in with my USB cable the car does not recognize that I have a USB device plugged in. My car does see my usb thumb drives and my ipod.

  6. #5
    Junior Member
    Join Date
    Aug 2012
    Location
    South Dakota
    Posts
    3
    I have an s3 and to get it to show the screen correct I start the music player on the phone first then it works just fine for me

  7. #6
    Junior Member
    Join Date
    Apr 2012
    Posts
    13
    I have a Verizon GS3 running the first experimental CM10 build. Sometimes I have to turn bluetooth off and on, but it generally always works. Sometimes the song title doesn't update on the screen, but it plays with good enough quality on the baseline sound system. It doesn't mess up the pitch like my Droid X used to.
    To potential buyers of the S3; do get this phone, but do /not/ get it on Verizon. The mandatory data cap really is that bad. I've got to go until the twenty sixth now without using a kilobyte more.

  8. #7
    Member
    Join Date
    Aug 2012
    Posts
    53
    Yea I'm running CM10 too with Jelly Bean so maybe that's the problem though when I first got my car I was running ICS. I still have unlimited data but I did pay full price for my S3 to keep unlimited but was able to trade my Nexus for $400.00 to cover the cost of it.

    satman2d are you running your phone stock ?

  9. #8
    Member
    Join Date
    Aug 2012
    Posts
    53
    Quote Originally Posted by satman2d View Post
    I have an s3 and to get it to show the screen correct I start the music player on the phone first then it works just fine for me
    Quote Originally Posted by coldcaption View Post
    I have a Verizon GS3 running the first experimental CM10 build. Sometimes I have to turn bluetooth off and on, but it generally always works. Sometimes the song title doesn't update on the screen, but it plays with good enough quality on the baseline sound system. It doesn't mess up the pitch like my Droid X used to.
    Did you do anything special to get the song titles to show up ? All I get is is the attached screen. Very frustrating.

    I've also not been able to get the car to see the phone when I use USB.
    Attached Images Attached Images  

  10. #9
    Senior Member
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    108
    Has there been any resolution to this issue? I just bought a GS3 and my Veloster doesn't even recognize it.

  11. #10
    Member rock_box's Avatar
    Join Date
    Nov 2012
    Location
    Mobile, Al Area
    Posts
    50
    I am having the same issue as the OP, except my phone is a GS2. I'm working with my rom's developer to see if we can get the issue solved...but if anyone has suggestions, I'm open to that as well.

    Jackal, please confirm you have the GS3 allowed to be viewable. That should be the only thing stopping the V and GS3 from being paired.

  12. #11
    Senior Member
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    108
    Rock Box, yes I have it so that it is viewable. Not sure WTF the problem is. Frustrating to say the least. The phone will pick up everything else around me but my car does not seem to recognize it.

  13. #12
    Member rock_box's Avatar
    Join Date
    Nov 2012
    Location
    Mobile, Al Area
    Posts
    50
    I'll re-pair my GS2 and V when I go on lunch so I can get you a step by step to pair them... I highly doubt there's that much difference in the BT settings between the GS2 and GS3.

    I'm also assuming you're running Android 4.0 Ice-Cream Sandwich too, and not 4.1 Jellybean :/ There is some difference in the BT connectivity between the two Android versions but I can't remember what. I installed AOKP 4.1 on my GS2 just for a trial run but 4.0.2 is easier on the battery, so I rolled back.

    If you are on Android 4.1, I can restore my 4.1 image and try that too...but it'll be after work before I could test.


    Update:
    Tested BT connection connected found and attempted to pair immediately on Android 4.0. I'll restore my Android 4.1 and test as soon as possible. Please, confirm 'Only visible to paired devices' is not checked.
    Last edited by rock_box; 11-27-2012 at 02:31 PM.

  14. #13
    Member
    Join Date
    Mar 2012
    Posts
    41
    I have no problems getting my GS3 to pair w my Veloster and stream music, but the song info or album cover art does not display. Also cannot get the Android version of Pandora to work with the built in Veloster Pandora app.

  15. #14
    Senior Member
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    108
    Rock Box I am running Android 4.1.1. I don't see an option on my phone that says "Only visible to paired devices" The only option I have is one that you check to be visible to other bluetooth devices.

  16. #15
    Senior Member
    Join Date
    Apr 2012
    Location
    Baltimore, MD
    Posts
    188
    OK - very simple and (now) obvious fix. This is the procedure: Press the Info/Setup hardkey on the headunit, then "Setup/Bluetooth/Advanced Setup/Restore Factory Settings". This will "reset" the head unit bluetooth to factory default values. This procedure will also delete all existing bluetooth connections and all contacts you may already had in head unit, so beware of the latter effect as you may have to add new contact info if it is not already transferred onto your new phone. I then ensured I removed the VELOSTER bluetooth connection on my own GS3 phone. So now both sides should be "clean and unpaired". I then had the head unit seek out all bluetooth radios and then turned on the VELOSTER bluetooth "found" on my phone screen (obviously ensure bluetooth radio is "on" during this procedure. I entered passkey of 0000 when asked. Once my phone and head unit synched up, I received a "download contacts?" question on my phone, and I said YES. Some phones for the GS3 will have this question come up on the head unit, so be aware of this difference - just be very attentive. Press YES upon this question. Within seconds, all my contacts transferred to the car's head unit (without a confirmation, by the way). Entire procedure sitting in drivers seat doing all of this took all of 3 minutes from beginning to end.

    Try the above exactly and report back.

  17. #16
    Senior Member
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    108
    I played with it last night and restored the factory settings to remove all contacts and to also removed my old HTC phone that was paired. I finally got the the GS3 paired but it was giving me a problem with downloading my contacts. It also for some unknown reason stayed paired but would not allow incoming or outgoing calls. I then turned the Blue Tooth setting to off on the phone and then turned it back on. At that point the phone connected and it also allowed me to download all of my contacts. Was it a glitch, who knows. Everything seems to be working thus far except it will not auto connect. I will play with it more once I get off work and will report back.

  18. #17
    Senior Member
    Join Date
    Apr 2012
    Location
    Baltimore, MD
    Posts
    188
    SJ - Glad that my directions got you almost there. On the GS3, there is an option on the bluetooth to never shut off. Might be under settings if memory serves. Make sure that is enabled. I don't have the phone w/me now to step you thru it. Also, if you have one of those battery saver apps or task manager apps on your phone, it will play havoc with the Bluetooth on the phone, so be aware of this possible conflict too. If you have any of these latter apps, ensure that it ignores Bluetooth from automatically turning off.

  19. #18
    Senior Member
    Join Date
    Jan 2012
    Location
    Texas
    Posts
    108
    I have given the phone a couple of days to see what it does. Basically my findings are that if you have Bluetooth set before you turn the car on, it auto connects right away. If you wait to turn it on after you start the car, it doesn't auto connect. I have to manually tell it to connect even though the phone says it is paired. With my HTC, it didn't matter how I did it, it would auto connect either way. At least I can pair the phone to the car. That was the main goal.

  20. #19
    Senior Member Gazuga's Avatar
    Join Date
    Feb 2012
    Location
    Manassas, VA
    Posts
    269
    I just picked up a GS3. Figured I'd give android a fair shot since the iPhone 5 is somewhat underwhelming. I really like the phone, but i too cannot get the phone to link via USB. I'm running 4.1 (updated through kies). Anybody had any luck with a stock android build?


    Sent from my iPhone using AutoGuide.com App
    "Talos" Triathlon Gray DCT w/Style Package
    Bought 5/3/12

  21. #20
    Junior Member Don D's Avatar
    Join Date
    Dec 2012
    Location
    CT
    Posts
    5

    Worked like a champ!

    Quote Originally Posted by short circuit View Post
    OK - very simple and (now) obvious fix. This is the procedure: Press the Info/Setup hardkey on the headunit, then "Setup/Bluetooth/Advanced Setup/Restore Factory Settings". This will "reset" the head unit bluetooth to factory default values. This procedure will also delete all existing bluetooth connections and all contacts you may already had in head unit, so beware of the latter effect as you may have to add new contact info if it is not already transferred onto your new phone. I then ensured I removed the VELOSTER bluetooth connection on my own GS3 phone. So now both sides should be "clean and unpaired". I then had the head unit seek out all bluetooth radios and then turned on the VELOSTER bluetooth "found" on my phone screen (obviously ensure bluetooth radio is "on" during this procedure. I entered passkey of 0000 when asked. Once my phone and head unit synched up, I received a "download contacts?" question on my phone, and I said YES. Some phones for the GS3 will have this question come up on the head unit, so be aware of this difference - just be very attentive. Press YES upon this question. Within seconds, all my contacts transferred to the car's head unit (without a confirmation, by the way). Entire procedure sitting in drivers seat doing all of this took all of 3 minutes from beginning to end.

    Try the above exactly and report back.
    This worked for me perfectly- the FS-LS went away (I got the car from an alternate source cuz the one I ordered was diverted- i think it was fiddled with) and the veloster appeared, and contacts even loaded without a hitch. I did not even have to reset the phone, it just ignored the FS-LS, saw veloster, and paired without issue- all I did was reset the velo's bluetooth to factory settings...
    Again, thanks much!

  22. Remove Advertisements
    Hyundai Veloster
    Advertisements
     

Similar Threads

  1. Samsung Galaxy S3 not auto-connecting on Bluetooth
    By siberdraknon in forum Hyundai Veloster Audio and Electronics
    Replies: 30
    Last Post: 02-11-2013, 11:17 AM
  2. Bluetooth
    By NDNcanella in forum Hyundai Veloster Audio and Electronics
    Replies: 6
    Last Post: 01-18-2013, 05:09 PM
  3. HTC One X Bluetooth
    By Hickerous in forum Hyundai Veloster Audio and Electronics
    Replies: 2
    Last Post: 07-31-2012, 10:35 PM
  4. Bluetooth HTC One X
    By FeedbakBWR in forum Hyundai Veloster General Discussion
    Replies: 0
    Last Post: 04-27-2012, 01:37 PM
  5. Bluetooth will not bind
    By Harrisons004 in forum Hyundai Veloster Audio and Electronics
    Replies: 12
    Last Post: 04-20-2012, 12:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2